package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([)?database(])?\.([)?dbo(]?)\.([?)table_name(]?)`)
var str = `database.dbo.table_name`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}