package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?P<name>[a-zA-Z0-9.!#$%&'*+/=?^_ \x60{|}~-]+)@(?P<domain>[a-zA-Z0-9](?:[a-zA-Z0-9-]{0,61}[a-zA-Z0-9])?(?:\.[a-zA-Z0-9](?:[a-zA-Z0-9-]{0,61}[a-zA-Z0-9])?)*)$`)
var str = `// https://html.spec.whatwg.org/#valid-e-mail-address
me@example.com
me@example.co.uk
me@example.new`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}