re = /(?<timestamp>[^ ]* [^ ]*) (?<level>[^\s][A-Z]+)[\s]+(?<thread>\s.*) (?<message>[\s\S]*)$/m
str = '2019-09-01 18:58:05,898 INFO Thread: qtp1497973286-16 - com.viasat.gms.ca.gen1.soapadapter
<with additional stuff>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end