const regex = new RegExp('(?P<bullet>\\d{1,2}\\.(?:[\\s\\S](?![a-z]\\.))+\\\\n)|(?P<letter>(?<=\\\\n)[a-z]\\.(?:[\\s\\S](?!\\-))+\\\\n)|(?P<dash>(?<=\\\\n)\\-(?:[\\s\\S](?!\\d{1,2}\\.))+?\\\\n)', 'gm')
const str = `"Opening: To achieve our vision of creating a diverse and engaging collection of board games, we will focus on the following strategic components:\\nStructure: Each component is designed to meet specific gameplay requirements:\\nTerminology: Components, strategy, gameplay requirements, design. Each sub-objective should be a more detailed and focused component of its parent objective, contributing to achieving the parent goal.\\n1. Develop a Comprehensive Game Library:\\na. Acquire games from Catan, Ticket to Ride, Pandemic, Codenames, and Azul to enrich the game library.\\n- Utilize publicly available resources provided by Catan, Ticket to Ride, Pandemic, Codenames, and Azul to strategically select games.\\n- Store acquired games in a organized format such as a database or inventory system for efficient retrieval and analysis.\\n2. Implement Star Trek Theme Integration:\\na. Leverage Star Trek themes and elements to enhance the gaming experience and attract fans of the franchise.\\n- Utilize open-source Star Trek assets such as images, quotes, and lore to incorporate into game components and designs.\\n- Use creative storytelling techniques to weave Star Trek narratives into the gameplay and objectives of selected games.\\n3. Enhance Player Engagement and Interaction:\\na. Incorporate real-time monitoring of player feedback and preferences to continuously update the game library.\\n- Utilize player surveys and open-source forums to gather up-to-date information on emerging trends and popular mechanics.\\n- Implement social media scraping techniques to extract relevant player insights from publicly available sources and discussions.\\n4. Establish Optimal Game Selection Strategies:\\na. Employ data analysis and player profiling algorithms to develop optimal game selection strategies for different player groups.\\n- Utilize data analysis to identify patterns in player preferences and behaviors based on demographics and gaming history.\\n- Implement player profiling strategies to anticipate and cater to the diverse interests and skill levels of different player segments.\\n5. Perform Game Session Analysis:\\na. Develop algorithms to analyze game sessions and identify potential areas for improvement in game balance, pacing, and player satisfaction.\\n- Utilize graph theory and network analysis tools to model player interactions and identify critical points in the game flow.\\n- Integrate data from playtesting sessions to profile and understand the progression of game sessions, enabling proactive game refinement strategies.\\nEach of these sub-objectives contributes to the overarching goal of creating a diverse and engaging collection of board games that caters to different player preferences. These specific tasks align with the project\\'s purpose of leveraging advanced techniques such as data analysis, player profiling, and Star Trek theme integration to achieve a comprehensive and satisfying board gaming experience for all players."
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}