import re
regex = re.compile(r"^((AT)(U\d{8})|(BE)(0\d{9})|(BG)(\d{9,10})|(CY)(\d{8}[LX])|(CZ)(\d{8,10})|(DE)(\d{9})|(DK)(\d{8})|(EE)(\d{9})|(EL|GR)(\d{9})|(ES)([\dA-Z]\d{7}[\dA-Z])|(FI)(\d{8})|(FR)([\dA-Z]{2}\d{9})|(HU)(\d{8})|(IE)(\d{7}[A-Z]{2})|(IT)(\d{11})|(LT)(\d{9}|\d{12})|(LU)(\d{8})|(LV)(\d{11})|(MT)(\d{8})|(NL)(\d{9}(B\d{2}|BO2))|(PL)(\d{10})|(PT)(\d{9})|(RO)(\d{2,10})|(SE)(\d{12})|(SI)(\d{8})|(SK)(\d{10}))$", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("ATU12345678\n"
"BE0123456789\n"
"BG123456789\n"
"BG1234567890\n"
"CY12345678X\n"
"CY12345678L\n"
"CZ12345678\n"
"CZ123456789\n"
"CZ1234567890\n"
"DE123456789\n"
"DK12345678\n"
"EE123456789\n"
"EL123456789\n"
"GR123456789\n"
"ESX12345678\n"
"ES12345678X\n"
"ESX1234567X\n"
"FI12345678\n"
"FR12345678901\n"
"FRX1234567890\n"
"FR1X123456789\n"
"FRXX123456789\n"
"HU12345678\n"
"IE1234567WA\n"
"IE1234567FA\n"
"IT12345678901\n"
"LT123456789\n"
"LT123456789012\n"
"LU12345678\n"
"LV12345678901\n"
"MT12345678\n"
"NL123456789B01\n"
"NL123456789BO2\n"
"PL1234567890\n"
"PT123456789\n"
"RO1234567890\n"
"SE123456789012\n"
"SK1234567890")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")