# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\s*([^#][\w\d_-]+?)\s*=\s*(.*)"
test_str = ("; This is a sample configuration file\n"
"; Comments start with ';', as in php.ini\n\n"
"[first_section]\n"
"one = 1\n"
"one = 3\n"
"one-two = 4\n"
"one_three = 3\n"
"five = 5.2\n"
"animal = BIRD\n\n"
"[first_section]\n"
"second_section[one] = \"1 associated\"\n"
"second_section[two] = \"2 associated\"\n"
"second_section[] = \"1 unassociated\"\n"
"second_section[] = \"2 unassociated\"\n"
"second_section[] = 1\n"
"second_section[] = 1,3\n"
"second_section[] = 2,2\n\n\n"
"[second_section]\n"
"path = \"/usr/local/bin\"\n"
"URL = \"http://www.example.com/~username\"\n"
"second_section[one] = \"1 associated\"\n"
"second_section[two] = \"2 associated\"\n"
"second_section[three] = 3\n"
"second_section[four] = 4.4\n"
"second_section[] = \"1 unassociated\"\n"
"second_section[] = \"2 unassociated\"\n"
"second_section[] = 1\n"
"second_section[] = 2.2\n\n"
"[third_section]\n"
"phpversion[] = \"5.0\"\n"
"phpversion[] = \"5.1\"\n"
"phpversion[] = \"5.2\"\n"
"phpversion[] = \"5.3\"")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.