$re = '/(?<=href=\'\/documents\/)(?<href>.*(?=\'))(?:.*?(?=>)>)(?<title>.*(?=<))/m';
$str = '<a href=\'/documents/aso2v51_1bk.pdf\' target="_blank">Ordering Model – Access Service Volume II – Analysis</a>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);