re = /<([^>]*)>[:|\s]+{(.*?)}/
str = '<First>: something <second>: {Second} something <Third>: {Third}'
# Print the match result
str.match(re) do |match|
puts match.to_s
end