package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)abc+`)
var str = `abcccd abccccc ab acd acccbbe `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}