$re = '/a{2}bc/m';
$str = 'abcccd abccccc ab acd acccbbe aabc aacb ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);