package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)ab{2}c`)
var str = `abcccd abccccc ab acd acccbbe aabc aacb abbbbbc abbc`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}