$re = '/a.+?c/m';
$str = 'abcccd abccccc ab acd acccbbe abc aacb abbbbbc abbc ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);