using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[~!@#$%^&*(){}_\\<>?\|-]";
string substitution = @"\\$0";
string input = @"~!@#$%^&*(){}_\<>?[]|-asd";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}