re = /(?=.*[0-9])(?=.*[!@#$%^&*])(?=.*[a-z])(?=.*[A-Z])[0-9a-zA-Z!@#$%^&*]{6,}/m
str = '7888g8994F'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end