$re = '/^[a-zA-Z_.\-\x80-\xff][a-zA-Z0-9_.\-\x80-\xff]*$/mu';
$str = 'mywebhook
my_webhook
my-webhook
éÿù
mywebh00k
1mywebh00k
my webhook
web🪝';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);