re = /^(.*?) = (.*(?:\R(?!.*? = ).*)*)$/m
str = 'groupid = foo
location = westus
randomkey = fbae3700c34cb06c
resourcename = example4-resourcegroup
tls_private_key = -----BEGIN RSA PRIVATE KEY-----
//stuff
-----END RSA PRIVATE KEY-----
foo = 123
faa = 223'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end