$re = '/^(00[1-9]|0[1-9]\d|[1-9]\d{2})$/';
$str = '001';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);