$re = '/\?(\w*)"/m';
$str = '<img src="folder/img1.jpg?somestring">
<img src="folder/img2.jpg?somediffstring">';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);