re = /(?:(?=(?<a>\w+)?)\k<a>(?:;(\w+?)=(\d+?))*?)?/
str = 'ab;c=1;d=2;e=f,ab;x=3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end