$re = '/\(\s*(.*\S)\s*\)/';
$str = 'node
( t-ur0wkjqky55s9mlh2rtt0u30r ) {
text ("[g:token.dice.Sum] roll the dice with (6)[v:token.dice.NumSides] sides (3)[v:token.dice.NumDice] times")
plan (Y2Bl4CnLLNNLyUxO1QsuzWUQhvOC8nNyglKLS3NKGARRBF2ADAYBuJBfaS5YRBBZJDgzJbWYgYWBkYGJgRlIM4BZIMjIAAHMYAyUAQA= )
}
node (t-vr0wkjqky55s9mlh2rtt0u301 ) {
text ("[g:token.dice.Sum] boll tha dice with (6)[v:token.dice.NumDice] side (3)[v:token.dice.NumSides] times" )
plan ( Y2Bl4CnLLNNLyUxO1QsuzWUQhvOC8nNyglKLS3NKGARRBF2ADAYBuJBfaS5YRBBZJDgzJbWYgYWBkYGJgRlIM4BZIMjIAAHMYAyUAQA=)
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);