#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(10[.][0-9]{4,}(?:[.][0-9]+)*/(?:(?![\"&\'<>];)\S)+)\b"
Local $sString = "https://www.example.com" & @CRLF & _
"http://www.example.com" & @CRLF & _
"www.example.com" & @CRLF & _
"example.com" & @CRLF & _
"http://blog.example.com" & @CRLF & _
"http://www.example.com/product" & @CRLF & _
"http://www.example.com/products?id=1&page=2" & @CRLF & _
"http://www.example.com#up" & @CRLF & _
"http://255.255.255.255" & @CRLF & _
"255.255.255.255" & @CRLF & _
"255.255.255.255/test" & @CRLF & _
"http://invalid.com/perl.cgi?key= | http://web-site.com/cgi-bin/perl.cgi?key1=value1&key2" & @CRLF & _
"http://www.site.com:8008" & @CRLF & _
"http://www.site.com:8008 10.1016.12.31/naTUrE.S0735-1097(98)2000/12/31/34:7-7 http://myrepo.example.org/ark:/12345/bcd987" & @CRLF & _
"" & @CRLF & _
"https://doi.org/10.3886/ICPSR06849 10.3886/ICPSR06849 https://www.icpsr.umich.edu/icpsrweb/NACJD/studies/6849/version/1" & @CRLF & _
"doi.org/10.1175/1520-0485(2002)032<0870:CT>2.0.CO;2" & @CRLF & _
"" & @CRLF & _
" self.crossref_dois = (" & @CRLF & _
" '10.2310/JIM.0b013e31820bab4c'," & @CRLF & _
" '10.1007/978-3-642-28108-2_19'," & @CRLF & _
" '10.1016/S0735-1097(98)00347-7'," & @CRLF & _
" )" & @CRLF & _
"" & @CRLF & _
" self.hard_dois = (" & @CRLF & _
" '10.1175/1520-0485(2002)032<0870:CT>2.0.CO;2'," & @CRLF & _
" '10.1002/(SICI)1522-2594(199911)42:5<952::AID-MRM16>3.0.CO;2-S'," & @CRLF & _
" '10.1579/0044-7447(2006)35\[89:RDUICP\]2.0.CO;2'," & @CRLF & _
" )" & @CRLF & _
"" & @CRLF & _
" self.currently_not_supported = (" & @CRLF & _
" '10.1007.10/978-3-642-28108-2_19'," & @CRLF & _
" '10.1000.10/123456'," & @CRLF & _
" '10.1016.12.31/nature.S0735-1097(98)2000/12/31/34:7-7'," & @CRLF & _
" )" & @CRLF & _
"" & @CRLF & _
" self.crossref_dois = (" & @CRLF & _
" 'doi.org/10.2310/JIM.0b013e31820bab4c'," & @CRLF & _
" 'doi.org/10.1007/978-3-642-28108-2_19'," & @CRLF & _
" 'doi.org/10.1016/S0735-1097(98)00347-7'," & @CRLF & _
" )" & @CRLF & _
"" & @CRLF & _
" self.hard_dois = (" & @CRLF & _
" 'doi.org/10.1175/1520-0485(2002)032<0870:CT>2.0.CO;2'," & @CRLF & _
" 'doi.org/10.1002/(SICI)1522-2594(199911)42:5<952::AID-MRM16>3.0.CO;2-S'," & @CRLF & _
" 'doi.org/10.1579/0044-7447(2006)35\[89:RDUICP\]2.0.CO;2'," & @CRLF & _
" )" & @CRLF & _
"" & @CRLF & _
" self.currently_not_supported = (" & @CRLF & _
" 'doi.org/10.1007.10/978-3-642-28108-2_19'," & @CRLF & _
" 'doi.org/10.1000.10/123456'," & @CRLF & _
" 'doi.org/10.1016.12.31/nature.S0735-1097(98)2000/12/31/34:7-7',"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")