#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!$|(?:\.*+\w++)?(?&sep)$)(?:\.(?&sep))?(?:(?<protocol>(?:file:(?<sep>\\|\/){3})?[A-Za-z]:(?&sep)|(?&sep){2}|https?:(?&sep){2})(?!$)(?<IP>(?:\d+\.){3}\d++(?::\d++)?(?:(?&sep)(?!$)|$))?|(?&sep))?(?<folder>(?:\w+|(?!\.(?&sep))\.{1,3}\w*|\w+\.\.?|\w+\.\w+)(?:(?&sep)|$))*$"
Local $sString = "Somewhat advanced help is required (this is like a boss fight)" & @CRLF & _
"" & @CRLF & _
"Hello dear people!" & @CRLF & _
"" & @CRLF & _
"background:" & @CRLF & _
"" & @CRLF & _
"i am creating an application that looks up both strings, and folders in the same time" & @CRLF & _
"" & @CRLF & _
"i would like to create a regex pattern to identify an uri in windows based on which my application may get a string, or reference to a folder in which there are multiple other files with strings, or so" & @CRLF & _
"" & @CRLF & _
"i expect only file:///, https?://, smb (the one starting with double slash), or no marked protocolls to work with" & @CRLF & _
"" & @CRLF & _
"my approach to this is that as i am reading an uri string, i am taking named groups of a match i am determining which kind of uri have i got from a user" & @CRLF & _
"" & @CRLF & _
"i am actually mostly complete already, and the purpose of this post is out of bug finding, or refactoring purpose, and i have got a newer version that does not work yet" & @CRLF & _
"" & @CRLF & _
"i am going to provide a currently working pattern that is ran in PHP 8.1.31 and PCRE 10.39 2021-10-29 that is working very flimsical because it for example requires multiple named groups for the same deal, because it can expect folders, and files to be named, but not trimmed, and sometimes it just runs into errors that render matching right by accident "does not match", however the thing is i do not wish to run into an error by accident, and then be unable to determine the required pattern correctly" & @CRLF & _
"" & @CRLF & _
"during refactoring i would like to avoid to use the backward kind of look around, and i would like to preserve the current way i determine which character may a folder name possess (i mean specifically the brackets' clause \[\^...\])" & @CRLF & _
"" & @CRLF & _
"i would also like to opt into the compatibility to other flavors specifically to google sheets, and notepad++ in this priority order with keeping the current pcre one (if possible)" & @CRLF & _
"" & @CRLF & _
"i have started to work on a new pattern that should be more robust, but i did not get it to work, and i would like to grant that regex pattern here as well with the exact same specifications, and almost the same if not exactly the same functionality as proclaimed, and as the current pattern works" & @CRLF & _
"" & @CRLF & _
"it is very important that i would like to rather focus on the ability to get every single possible deal into a variable via a named group, to actually match anything" & @CRLF & _
"" & @CRLF & _
"deals to get via named groupings:" & @CRLF & _
"" & @CRLF & _
"what is the relative path if any (including relative paths that does not name any folder, nany file)" & @CRLF & _
"" & @CRLF & _
"what is the root folder if any (including relative path, smb root ("//" and so), drive (c:/), including any protocoll all the way up to double, or triple slashes for example "file:///c:/" counts as a root, but "c:/" also counts as a root)" & @CRLF & _
"" & @CRLF & _
"what is the last folder name in the path if it is not a file (a separator character will explicitly determine the last name as a folder name in case its name contains a dot, else it is a file when its name contains a dot)" & @CRLF & _
"" & @CRLF & _
"what is the file name if any (with the difference that files may possess extensions, yet folder names may contain dots, and after a file name there can not be a separator character)" & @CRLF & _
"" & @CRLF & _
"what is the file extension if any (with 3 types of extensions i expect out of which one is any extension)" & @CRLF & _
"" & @CRLF & _
"whether the file is with .lnk extension (such that i can recursively go as deep as i please)" & @CRLF & _
"" & @CRLF & _
"whether the file is with .url extension" & @CRLF & _
"" & @CRLF & _
"what is the ipv4 if any (i expect to be able to both refer solely to the ip with the respective protocol before it, and to refer to any path under the ip)" & @CRLF & _
"" & @CRLF & _
"what is the path from the first letter up until the name of the folder, or file (with either one excluded such that i will be able to create a file into the given folder before i attempt to read anything)" & @CRLF & _
"" & @CRLF & _
"bonus deal: i did not figure out a way to name the separator anything, so i would like to know what the separator is because as of my current knowledge it can either be backslash, or forward slash, yet both my current patterns only work with the forward one" & @CRLF & _
"" & @CRLF & _
"expected match, and ~~mismatch~~ examples to both current, and new patterns" & @CRLF & _
"" & @CRLF & _
"i expect to be able to recognize any folder both alone, and along the path in the following ways:" & @CRLF & _
"" & @CRLF & _
"PASS " & @CRLF & _
"./" & @CRLF & _
"../" & @CRLF & _
"folder_name" & @CRLF & _
".folder" & @CRLF & _
"..folder" & @CRLF & _
"folder." & @CRLF & _
"fodler.." & @CRLF & _
"folder.txt/" & @CRLF & _
"" & @CRLF & _
"i expect relative paths to be recognized" & @CRLF & _
"" & @CRLF & _
"PASS " & @CRLF & _
"../../../" & @CRLF & _
"./../../" & @CRLF & _
"" & @CRLF & _
"i expect paths that can be joined to another folder recognized" & @CRLF & _
"" & @CRLF & _
"PASS " & @CRLF & _
"/folder/file.txt" & @CRLF & _
"" & @CRLF & _
"i expect separator character to not be before any protocol" & @CRLF & _
"" & @CRLF & _
"FAIL " & @CRLF & _
"///server" & @CRLF & _
"/http://folder" & @CRLF & _
"/c:/folder/folder" & @CRLF & _
"" & @CRLF & _
"PASS " & @CRLF & _
"C:/fodler/dofler/difle.dxd" & @CRLF & _
"" & @CRLF & _
"i expect to be able to name any file a dot (witht the file's name possibly only the last one in the path)" & @CRLF & _
"" & @CRLF & _
"PASS " & @CRLF & _
"..txt" & @CRLF & _
"" & @CRLF & _
"FAIL " & @CRLF & _
"..txt/" & @CRLF & _
"" & @CRLF & _
"PASS " & @CRLF & _
"...txt" & @CRLF & _
"../..txt" & @CRLF & _
"../folder/..txt" & @CRLF & _
"../folder/..txt/" & @CRLF & _
"" & @CRLF & _
"i expect that a folder name along the path, and the last folder's name is not expected to be a dot, or two dots, but "close calls" are expected" & @CRLF & _
"" & @CRLF & _
"FAIL " & @CRLF & _
".././other/.././folder." & @CRLF & _
"" & @CRLF & _
"PASS " & @CRLF & _
"../f./other/..f/.d/folder." & @CRLF & _
"" & @CRLF & _
"i expect that when i refer to an ip address i must use the protocoll before it" & @CRLF & _
"" & @CRLF & _
"FAIL " & @CRLF & _
"123.123.123.123:234" & @CRLF & _
"" & @CRLF & _
"PASS " & @CRLF & _
"http://123.123.123.123:234" & @CRLF & _
"" & @CRLF & _
"FAIL " & @CRLF & _
"123.123.123.123" & @CRLF & _
"" & @CRLF & _
"PASS " & @CRLF & _
"http://123.123.123.123" & @CRLF & _
"https://823.123.123.123:2340" & @CRLF & _
"https://823.123.123.123:2340" & @CRLF & _
"https://823.123.123.123" & @CRLF & _
"https://823.123.123.123" & @CRLF & _
"" & @CRLF & _
"i expect that i can have the same folder, and file structure after i have used ipv4 with its protocoll" & @CRLF & _
"" & @CRLF & _
"PASS " & @CRLF & _
"https://823.123.123.123:234/notfile./.folder/some_more_folders/..txt" & @CRLF & _
"https://823.123.123.123:234/notfile./.folder/some_more_folders/..txt" & @CRLF & _
"https://823.123.123.123:234/notfile./.folder/some_more_folders/..txt/" & @CRLF & _
"https://823.123.123.123:234/notfile./.folder/some_more_folders/..txt/" & @CRLF & _
"" & @CRLF & _
"i expect that i can not use an ipv4 as a folder itself" & @CRLF & _
"" & @CRLF & _
"PASS " & @CRLF & _
"https://823.123.123.123:2340" & @CRLF & _
"https://823.123.123.123:2340" & @CRLF & _
"" & @CRLF & _
"FAIL " & @CRLF & _
"https://823.123.123.123:234/" & @CRLF & _
"" & @CRLF & _
"PASS " & @CRLF & _
"https://823.123.123.123:234" & @CRLF & _
"https://823.123.123.123" & @CRLF & _
"https://823.123.123.123" & @CRLF & _
"" & @CRLF & _
"FAIL " & @CRLF & _
"https://823.123.123.123/" & @CRLF & _
"" & @CRLF & _
"PASS " & @CRLF & _
"https://823.123.123.123" & @CRLF & _
"" & @CRLF & _
"i expect protocols to not be alone" & @CRLF & _
"" & @CRLF & _
"FAIL " & @CRLF & _
"http://" & @CRLF & _
"file:///" & @CRLF & _
"file:///C:/" & @CRLF & _
"" & @CRLF & _
"PASS " & @CRLF & _
"C:/folder" & @CRLF & _
"c:/folder" & @CRLF & _
"" & @CRLF & _
"i expect that i can not stack separators along the path, for example just two slashes indicate smb protocoll, but without anything else, i would not use it" & @CRLF & _
"FAIL " & @CRLF & _
"//" & @CRLF & _
"" & @CRLF & _
"PASS " & @CRLF & _
"//server" & @CRLF & _
"//anything" & @CRLF & _
"" & @CRLF & _
"FAIL " & @CRLF & _
"//server//folder" & @CRLF & _
"" & @CRLF & _
"PASS " & @CRLF & _
"//server/folder" & @CRLF & _
"" & @CRLF & _
"FAIL " & @CRLF & _
"file://c:/folder" & @CRLF & _
"" & @CRLF & _
"PASS " & @CRLF & _
"file:///c:/folder" & @CRLF & _
"" & @CRLF & _
"FAIL " & @CRLF & _
"file:///c:/folder//" & @CRLF & _
"" & @CRLF & _
"PASS " & @CRLF & _
"file:///c:/folder/..txt" & @CRLF & _
"" & @CRLF & _
"FAIL " & @CRLF & _
"file:///c:/folder//..txt" & @CRLF & _
"file:///c:/folder//folder" & @CRLF & _
"c://" & @CRLF & _
"" & @CRLF & _
"i a am done with matches, and mismatches. let me provide you the new prototype not working pattern, and then the current that works (to some extent)" & @CRLF & _
"" & @CRLF & _
"next..." & @CRLF & _
"" & @CRLF & _
" (" & @CRLF & _
" ?#all definitions first..." & @CRLF & _
" )" & @CRLF & _
" (" & @CRLF & _
" ?" & @CRLF & _
" (" & @CRLF & _
" DEFINE" & @CRLF & _
" )" & @CRLF & _
" (" & @CRLF & _
" ?'separator_s'" & @CRLF & _
" \/" & @CRLF & _
" )" & @CRLF & _
" (" & @CRLF & _
" ?'smb_root_s'" & @CRLF & _
" \g'separator_s'{2}" & @CRLF & _
" )" & @CRLF & _
" (" & @CRLF & _
" ?'root_middle_s'" & @CRLF & _
" \:" & @CRLF & _
" \g'separator_s'{2}" & @CRLF & _
" )" & @CRLF & _
" (" & @CRLF & _
" ?'drive_root_s'[a-z]" & @CRLF & _
" \:" & @CRLF & _
" \g'separator_s'" & @CRLF & _
" )" & @CRLF & _
" (" & @CRLF & _
" ?'file_root_s'file" & @CRLF & _
" \g'root_middle_s'" & @CRLF & _
" \g'separator_s'" & @CRLF & _
" \g'drive_root_s'" & @CRLF & _
" )" & @CRLF & _
" (" & @CRLF & _
" ?'ip_num_s'" & @CRLF & _
" \d{1,3}" & @CRLF & _
" )" & @CRLF & _
" (" & @CRLF & _
" ?'ipv4_gate_s'" & @CRLF & _
" \d+" & @CRLF & _
" )" & @CRLF & _
" (" & @CRLF & _
" ?'web_root_s'https?" & @CRLF & _
" \g'root_middle_s'" & @CRLF & _
" )" & @CRLF & _
" (" & @CRLF & _
" ?'ipv4_s'" & @CRLF & _
" (" & @CRLF & _
" ?:" & @CRLF & _
" \g'ip_num_s'" & @CRLF & _
" \." & @CRLF & _
" )" & @CRLF & _
" {3}" & @CRLF & _
" \g'ip_num_s'" & @CRLF & _
" (" & @CRLF & _
" ?:" & @CRLF & _
" \:" & @CRLF & _
" \g'ipv4_gate_s'" & @CRLF & _
" )" & @CRLF & _
" ?" & @CRLF & _
" )" & @CRLF & _
" (" & @CRLF & _
" ?'separator_root_s'" & @CRLF & _
" \g'separator_s'?" & @CRLF & _
" )" & @CRLF & _
" (" & @CRLF & _
" ?'relative_root_s'" & @CRLF & _
" \.{1,2}" & @CRLF & _
" \g'separator_s'" & @CRLF & _
" (" & @CRLF & _
" ?:" & @CRLF & _
" \.{2}" & @CRLF & _
" \g'separator_s'" & @CRLF & _
" )" & @CRLF & _
" *" & @CRLF & _
" )" & @CRLF & _
" (" & @CRLF & _
" ?'not_name_s'[^\v\t\\\/\:\*\"\?\<\>\|]" & @CRLF & _
" )" & @CRLF & _
" (" & @CRLF & _
" ?'not_name_nand_dot_s'[^\.\v\t\\\/\:\*\"\?\<\>\|]" & @CRLF & _
" )" & @CRLF & _
" (" & @CRLF & _
" ?'any_extension_s'[a-z0-9]" & @CRLF & _
" )" & @CRLF & _
" (" & @CRLF & _
" ?'any_name_s'" & @CRLF & _
" (" & @CRLF & _
" ?:" & @CRLF & _
" \g'not_name_nand_dot_s'" & @CRLF & _
" \g'not_name_s'*?|" & @CRLF & _
" \." & @CRLF & _
" \g'not_name_nand_dot_s'" & @CRLF & _
" \g'not_name_s'*?|" & @CRLF & _
" \.{1,2}" & @CRLF & _
" (" & @CRLF & _
" ?=" & @CRLF & _
" \." & @CRLF & _
" \g'any_extension_s'" & @CRLF & _
" )" & @CRLF & _
" |" & @CRLF & _
" \." & @CRLF & _
" \." & @CRLF & _
" \g'not_name_s'+?" & @CRLF & _
" )" & @CRLF & _
" )" & @CRLF & _
" (" & @CRLF & _
" ?'body_s'" & @CRLF & _
" (" & @CRLF & _
" ?:" & @CRLF & _
" \g'any_name_s'" & @CRLF & _
" \g'separator_s'" & @CRLF & _
" )" & @CRLF & _
" *" & @CRLF & _
" )" & @CRLF & _
" )" & @CRLF & _
" (" & @CRLF & _
" ?#definition has ended, pattern from now on" & @CRLF & _
" )" & @CRLF & _
" ^" & @CRLF & _
" (" & @CRLF & _
" ?<body>" & @CRLF & _
" (" & @CRLF & _
" ?<root>" & @CRLF & _
" \g'file_root_s'|" & @CRLF & _
" \g'drive_root_s'|" & @CRLF & _
" \g'smb_root_s'|" & @CRLF & _
" (" & @CRLF & _
" ?<relative_root>" & @CRLF & _
" \g'relative_root_s'" & @CRLF & _
" )" & @CRLF & _
" |" & @CRLF & _
" (" & @CRLF & _
" ?<separator_root>" & @CRLF & _
" \g'separator_root_s'" & @CRLF & _
" )" & @CRLF & _
" |" & @CRLF & _
" (" & @CRLF & _
" ?<web_root>" & @CRLF & _
" \g'web_root_s'" & @CRLF & _
" )" & @CRLF & _
" (" & @CRLF & _
" ?:" & @CRLF & _
" (" & @CRLF & _
" ?<ipv4>" & @CRLF & _
" \g'ipv4_s'" & @CRLF & _
" )" & @CRLF & _
" \g'separator_s'" & @CRLF & _
" )" & @CRLF & _
" ?" & @CRLF & _
" )" & @CRLF & _
" ?" & @CRLF & _
" \g'body_s'" & @CRLF & _
" )" & @CRLF & _
" (" & @CRLF & _
" ?:" & @CRLF & _
" \k<relative_root>|" & @CRLF & _
" \k<web_root>" & @CRLF & _
" \k<ipv4>|" & @CRLF & _
" \k<body>" & @CRLF & _
" (" & @CRLF & _
" ?<name>" & @CRLF & _
" \g'any_name_s'" & @CRLF & _
" )" & @CRLF & _
" (" & @CRLF & _
" ?:" & @CRLF & _
" \g'separator_s'|" & @CRLF & _
" (" & @CRLF & _
" ?:" & @CRLF & _
" \." & @CRLF & _
" (" & @CRLF & _
" ?:" & @CRLF & _
" (" & @CRLF & _
" ?<shortcut_extension>lnk" & @CRLF & _
" )" & @CRLF & _
" |" & @CRLF & _
" (" & @CRLF & _
" ?<web_extension>url" & @CRLF & _
" )" & @CRLF & _
" |" & @CRLF & _
" (" & @CRLF & _
" ?<non_particular_extension>" & @CRLF & _
" \g'any_extension_s'+" & @CRLF & _
" )" & @CRLF & _
" )" & @CRLF & _
" )" & @CRLF & _
" )" & @CRLF & _
" ?" & @CRLF & _
" )" & @CRLF & _
" $" & @CRLF & _
" " & @CRLF & _
" (" & @CRLF & _
" ?#all definitions first..." & @CRLF & _
" )" & @CRLF & _
" (" & @CRLF & _
" ?" & @CRLF & _
" (" & @CRLF & _
" DEFINE" & @CRLF & _
" )" & @CRLF & _
" (" & @CRLF & _
" ?'separator_s'" & @CRLF & _
" \/" & @CRLF & _
" )" & @CRLF & _
" (" & @CRLF & _
" ?'smb_root_s'" & @CRLF & _
" \g'separator_s'{2}" & @CRLF & _
" )" & @CRLF & _
" (" & @CRLF & _
" ?'root_middle_s'" & @CRLF & _
" \:" & @CRLF & _
" \g'separator_s'{2}" & @CRLF & _
" )" & @CRLF & _
" (" & @CRLF & _
" ?'drive_root_s'[a-z]" & @CRLF & _
" \:" & @CRLF & _
" \g'separator_s'" & @CRLF & _
" )" & @CRLF & _
" (" & @CRLF & _
" ?'file_root_s'file" & @CRLF & _
" \g'root_middle_s'" & @CRLF & _
" \g'separator_s'" & @CRLF & _
" \g'drive_root_s'" & @CRLF & _
" )" & @CRLF & _
" (" & @CRLF & _
" ?'ip_num_s'" & @CRLF & _
" \d{1,3}" & @CRLF & _
" )" & @CRLF & _
" (" & @CRLF & _
" ?'ipv4_gate_s'" & @CRLF & _
" \d+" & @CRLF & _
" )" & @CRLF & _
" (" & @CRLF & _
" ?'web_root_s'https?" & @CRLF & _
" \g'root_middle_s'" & @CRLF & _
" )" & @CRLF & _
" (" & @CRLF & _
" ?'ipv4_s'" & @CRLF & _
" (" & @CRLF & _
" ?:" & @CRLF & _
" \g'ip_num_s'" & @CRLF & _
" \." & @CRLF & _
" )" & @CRLF & _
" {3}" & @CRLF & _
" \g'ip_num_s'" & @CRLF & _
" (" & @CRLF & _
" ?:" & @CRLF & _
" \:" & @CRLF & _
" \g'ipv4_gate_s'" & @CRLF & _
" )" & @CRLF & _
" ?" & @CRLF & _
" )" & @CRLF & _
" (" & @CRLF & _
" ?'separator_root_s'" & @CRLF & _
" \g'separator_s'?" & @CRLF & _
" )" & @CRLF & _
" (" & @CRLF & _
" ?'relative_root_s'" & @CRLF & _
" \.{1,2}" & @CRLF & _
" \g'separator_s'" & @CRLF & _
" (" & @CRLF & _
" ?:" & @CRLF & _
" \.{2}" & @CRLF & _
" \g'separator_s'" & @CRLF & _
" )" & @CRLF & _
" *" & @CRLF & _
" )" & @CRLF & _
" (" & @CRLF & _
" ?'not_name_s'[^\v\t\\\/\:\*\""\?\<\>\|]" & @CRLF & _
" )" & @CRLF & _
" (" & @CRLF & _
" ?'not_name_nand_dot_s'[^\.\v\t\\\/\:\*\""\?\<\>\|]" & @CRLF & _
" )" & @CRLF & _
" (" & @CRLF & _
" ?'any_extension_s'[a-z0-9]" & @CRLF & _
" )" & @CRLF & _
" (" & @CRLF & _
" ?'any_name_s'" & @CRLF & _
" (" & @CRLF & _
" ?:" & @CRLF & _
" \g'not_name_nand_dot_s'" & @CRLF & _
" \g'not_name_s'*?|" & @CRLF & _
" \." & @CRLF & _
" \g'not_name_nand_dot_s'" & @CRLF & _
" \g'not_name_s'*?|" & @CRLF & _
" \.{1,2}" & @CRLF & _
" (" & @CRLF & _
" ?=" & @CRLF & _
" \." & @CRLF & _
" \g'any_extension_s'" & @CRLF & _
" )" & @CRLF & _
" |" & @CRLF & _
" \." & @CRLF & _
" \." & @CRLF & _
" \g'not_name_s'+?" & @CRLF & _
" )" & @CRLF & _
" )" & @CRLF & _
" (" & @CRLF & _
" ?'body_s'" & @CRLF & _
" (" & @CRLF & _
" ?:" & @CRLF & _
" \g'any_name_s'" & @CRLF & _
" \g'separator_s'" & @CRLF & _
" )" & @CRLF & _
" *" & @CRLF & _
" )" & @CRLF & _
" )" & @CRLF & _
" (" & @CRLF & _
" ?#definition has ended, pattern from now on" & @CRLF & _
" )" & @CRLF & _
" ^" & @CRLF & _
" (" & @CRLF & _
" ?<relative_root_excluzive_body>" & @CRLF & _
" (" & @CRLF & _
" ?<excluzive_relative_root>" & @CRLF & _
" \g'relative_root_s'" & @CRLF & _
" )" & @CRLF & _
" )" & @CRLF & _
" (" & @CRLF & _
" ?=$" & @CRLF & _
" )" & @CRLF & _
" |" & @CRLF & _
" (" & @CRLF & _
" ?:" & @CRLF & _
" (" & @CRLF & _
" ?<web_root_excluzive_body>" & @CRLF & _
" \g'web_root_s'" & @CRLF & _
" )" & @CRLF & _
" (" & @CRLF & _
" ?<excluzive_ipv4>" & @CRLF & _
" \g'ipv4_s'" & @CRLF & _
" )" & @CRLF & _
" )" & @CRLF & _
" (" & @CRLF & _
" ?=$" & @CRLF & _
" )" & @CRLF & _
" |" & @CRLF & _
" (" & @CRLF & _
" ?:" & @CRLF & _
" (" & @CRLF & _
" ?<body>" & @CRLF & _
" (" & @CRLF & _
" ?:" & @CRLF & _
" \g'file_root_s'|" & @CRLF & _
" \g'drive_root_s'|" & @CRLF & _
" \g'smb_root_s'|" & @CRLF & _
" (" & @CRLF & _
" ?<relative_root>" & @CRLF & _
" \g'relative_root_s'" & @CRLF & _
" )" & @CRLF & _
" |" & @CRLF & _
" (" & @CRLF & _
" ?<separator_root>" & @CRLF & _
" \g'separator_root_s'" & @CRLF & _
" )" & @CRLF & _
" |" & @CRLF & _
" (" & @CRLF & _
" ?<web_root>" & @CRLF & _
" \g'web_root_s'" & @CRLF & _
" )" & @CRLF & _
" (" & @CRLF & _
" ?:" & @CRLF & _
" (" & @CRLF & _
" ?<ipv4>" & @CRLF & _
" \g'ipv4_s'" & @CRLF & _
" )" & @CRLF & _
" \g'separator_s'" & @CRLF & _
" )" & @CRLF & _
" ?" & @CRLF & _
" )" & @CRLF & _
" ?" & @CRLF & _
" \g'body_s'" & @CRLF & _
" )" & @CRLF & _
" (" & @CRLF & _
" ?<name>" & @CRLF & _
" \g'any_name_s'" & @CRLF & _
" )" & @CRLF & _
" (" & @CRLF & _
" ?:" & @CRLF & _
" \g'separator_s'|" & @CRLF & _
" (" & @CRLF & _
" ?<extension>" & @CRLF & _
" \." & @CRLF & _
" (" & @CRLF & _
" ?:" & @CRLF & _
" (" & @CRLF & _
" ?<shortcut_extension>lnk" & @CRLF & _
" )" & @CRLF & _
" |" & @CRLF & _
" (" & @CRLF & _
" ?<web_extension>url" & @CRLF & _
" )" & @CRLF & _
" |" & @CRLF & _
" (" & @CRLF & _
" ?<non_particular_extension>" & @CRLF & _
" \g'any_extension_s'+" & @CRLF & _
" )" & @CRLF & _
" )" & @CRLF & _
" )" & @CRLF & _
" )" & @CRLF & _
" ?" & @CRLF & _
" )" & @CRLF & _
" $"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")