import Foundation
let pattern = #"^(?'username'.*):.*:(?'UID'.*):(?'GID'.*):(?'GECOS'.*):(?'home'.*):(?'shell'.*)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
root:x:0:0:Root User:/root:/bin/bash
john:x:1001:1001:John Smith,Room 101,+11234567890,,johnsmith@email.com:/home/john:/bin/bash
jane:x:1002:1002:Jane Doe,Room 102,+442012345678,,jane.doe@email.co.uk:/home/jane:/bin/bash
mike:x:1003:1003:Michael Johnson,Room 201,+498912345678,,michael.johnson@email.de:/home/mike:/bin/bash
sarah:x:1004:1004:Sarah Brown,Room 202,+61255512345,,sarah.brown@email.au:/home/sarah:/bin/bash
karen:x:1005:1005:Karen Miller,Room 203,+12155551234,,karen.miller@email.com:/home/karen:/bin/bash
jason:x:1006:1006:Jason Lee,Room 204,+81312345678,,jason.lee@email.jp:/home/jason:/bin/bash
steve:x:1007:1007:Steven Wilson,Room 205,+33123456789,,steven.wilson@email.fr:/home/steve:/bin/bash
emma:x:1008:1008:Emma Johnson,Room 206,+13455551234,,emma.johnson@email.com:/home/emma:/bin/bash
olivia:x:1009:1009:Olivia Brown,Room 207,+441234567890,,olivia.brown@email.co.uk:/home/olivia:/bin/bash
lucas:x:1010:1010:Lucas White,Room 208,+61455512345,,lucas.white@email.au:/home/lucas:/bin/bash
isabella:x:1011:1011:Isabella Adams,Room 209,+41123456789,,isabella.adams@email.ch:/home/isabella:/bin/bash
liam:x:1012:1012:Liam Thompson,Room 210,+17345551234,,liam.thompson@email.com:/home/liam:/bin/bash
noah:x:1013:1013:Noah Scott,Room 211,+17345551235,,noah.scott@email.com:/home/noah:/bin/bash
ava:x:1014:1014:Ava Clark,Room 212,+61255512346,,ava.clark@email.au:/home/ava:/bin/bash
sophia:x:1015:1015:Sophia Turner,Room 213,+33123456790,,sophia.turner@email.fr:/home/sophia:/bin/bash
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)