#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?si)(?:^(?<!.)|\R{2})\K(?:(?!\R{2}).)*?\bfifa\b.*?(?=\R{2}|\z)"
Local $sString = "Region: AR" & @CRLF & _
"OnlineID: Atl_Tuc" & @CRLF & _
"---Start---" & @CRLF & _
"FIFA 18 Legacy Edition" & @CRLF & _
"---END---" & @CRLF & _
"" & @CRLF & _
"Region: FR" & @CRLF & _
"OnlineID: jubtrrzz" & @CRLF & _
"---Start---" & @CRLF & _
"FIFA 19" & @CRLF & _
"Undertale" & @CRLF & _
"Pro Evolution Soccer™ 2018" & @CRLF & _
"---END---" & @CRLF & _
"" & @CRLF & _
"Region: US" & @CRLF & _
"OnlineID: Cu128yi" & @CRLF & _
"---Start---" & @CRLF & _
"KINGDOM HEARTS HD 1.5 +2.5 ReMIX" & @CRLF & _
"---END---" & @CRLF & _
"" & @CRLF & _
"Region: RO" & @CRLF & _
"OnlineID: Se116" & @CRLF & _
"---Start---" & @CRLF & _
"Real Farm" & @CRLF & _
"EA SPORTS™ FIFA 20" & @CRLF & _
"LittleBigPlanet™ 3" & @CRLF & _
"---END---" & @CRLF & _
"" & @CRLF & _
"Region: US" & @CRLF & _
"OnlineID: CAJ5Y" & @CRLF & _
"---Start---" & @CRLF & _
"Madden NFL 18: G.O.A.T. Super Bowl Edition" & @CRLF & _
"---END---"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")