import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?si)(?:^(?<!.)|\\R{2})\\K(?:(?!\\R{2}).)*?(?-s:\\bfifa\\b.*\\b20\\b).*?(?=\\R{2}|\\z)";
final String string = "Region: AR\n"
+ "OnlineID: Atl_Tuc\n"
+ "---Start---\n"
+ "FIFA 18 Legacy Edition\n"
+ "---END---\n\n"
+ "Region: FR\n"
+ "OnlineID: jubtrrzz\n"
+ "---Start---\n"
+ "FIFA 19\n"
+ "Undertale\n"
+ "Pro Evolution Soccer™ 2018\n"
+ "---END---\n\n"
+ "Region: US\n"
+ "OnlineID: Cu128yi\n"
+ "---Start---\n"
+ "KINGDOM HEARTS HD 1.5 +2.5 ReMIX\n"
+ "---END---\n\n"
+ "Region: RO\n"
+ "OnlineID: Se116\n"
+ "---Start---\n"
+ "Real Farm\n"
+ "EA SPORTS™ FIFA 20\n"
+ "LittleBigPlanet™ 3\n"
+ "---END---\n\n"
+ "Region: US\n"
+ "OnlineID: CAJ5Y\n"
+ "---Start---\n"
+ "Madden NFL 18: G.O.A.T. Super Bowl Edition\n"
+ "---END---";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}