$re = '/\((?:[^)(]*|\((?:[^)(]*|\((?:[^)(]*|\([^)(]*\))*\))*\))*\)/';
$str = 'some text(text here(possible text)text(possible text(more text))end text
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);