package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[([^]]*)\-\>([^]]*)\]`)
var str = `« ...] une collection de guides "surprises" s’adressant tout autant aux visiteurs désireux d’éviter les attrape-touristes qu’aux habitants impatients de dénicher les perles les mieux cachées de leur ville. […] Que l’on souhaite monter dans un bus dont le trajet permet d’admirer les plus beaux monuments de la ville, aller pique-niquer dans un jardin secret en plein cœur du quartier historique ou s’initier à l’art du thé dans une maison d’exception, les guides surprises ont la réponse ! »
(Le Messager.fr, janvier 2015)
[Lire l'article complet->http://loisirs.lemessager.fr/magazine/voyage/europe/article/les-meilleures-adresses-de-la-ville.html]
[dont capture this][Lire l'article complet->http://loisirs.lemessager.fr/magazine/voyage/europe/article/les-meilleures-adresses-de-la-ville.html]
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}