using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[\[((?:(?!\[\[|\][\]\[]).)*)\]\[(.*?)\]\]";
string input = @"[[two b][three c]]
[[one a]]
[[one a]] and [[two b][three c]]
[[no [match][three c]]
[[no mat]ch][three c]]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}