#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mxi)^ \h*+ (?:substr[(])? (?: Z.VALUE_01 ) (?:,[^,]+,[^,]+[)])? \h* as \h+ (\w+) \v* ,? \v* $"
Local $sString = "--> Some comment" & @CRLF & _
"" & @CRLF & _
"CREATE VIEW ABC" & @CRLF & _
" AS SELECT" & @CRLF & _
" Z.NUMBER AS ID," & @CRLF & _
" Z.LANGUAGE AS LNG," & @CRLF & _
" SUBSTR(Z.VALUE_01,01,02) AS RUN_NUMB," & @CRLF & _
" SUBSTR(Z.TXT_VALUE_01,01,79) AS TXT" & @CRLF & _
" FROM" & @CRLF & _
" MYTABLE Z" & @CRLF & _
" WHERE ID = '0033'" & @CRLF & _
" AND LNG = 'DE'" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")