package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)1\.1\.1\.(?:19[1-9]|2[01]\d|220)`)
var str = `1.1.1.100
1.1.1.200
1.1.1.192
1.1.1.196
1.1.1.202
1.1.1.201
1.1.1.220
1.1.1.222
1.1.1.225
1.1.1.230
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}