$re = '/(\d{9}|\d{3}[ ]\d{3}[ ]\d{3})/';
$str = '456 456 456
454545454';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);