$re = '~/[^@\n]*(?:@(?!gram_bot)[^@\n]*)*~m';
$str = '/echo@gram_bot
/echo';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);