package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\n|\r\n|[^\r\n]++(\r\n|\n)?`)
var str = `uno
due
tre`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}