re = /[a-zA-Z]+(?![a-zA-Z])(?<!(?<![a-zA-Z])banana)/m
str = '0827banana82/+wine22green-729
straigtbanana bananas'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end