$re = '/(?:[a-z0-9-]+\.)?(.*)/m';
$str = 'cualquier-subdominio.pagina.com
pagina.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);