$re = '/^\d*\.[1-9]*([0]+)*$/';
$str = '9.2500';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);