package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(?:[^\/]*\/){7}([^\/]+).*$`)
var str = `/a/b/c/d/e/f/g/h/i`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}