using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?=([bc]*[a]){3})(?=([ac]*[b]){3})(?=([ab]*[c]){3,})[abc]+|(?=([b]*[a]){3})(?=([a]*[b]){3})[ab]+)";
string input = @"aaabbb
ababab
aaabbbccc
abcabcabc
ababcabcc
aaabbbc
aabbb
abbccc
abcabca";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}