$re = '/^035\s[0-9]{15}$/m';
$str = '
035 000000000000000
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);