# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[^\d]*(\d+)\s*?(\d+).*"
test_str = ("Tipo 1 3 3 X \n"
"CNPJ do declarante 4 17 14 CNPJ \n"
"Ano-calendário 18 21 4 ANO \n"
"Sequencial da Locação 22 26 5 N \n"
"CPF/CNPJ do Locador 27 40 14 CPF/CNPJ \n"
"Nome/Nome Empresarial do Locador 41 100 60 X \n"
"CPF/CNPJ do Locatário 101 114 14 CPF/CNPJ2 \n"
"Nome/Nome Empresarial do Locatário 115 174 60 X \n"
"Número do Contrato 175 180 6 X \n"
"Data do Contrato 181 188 8 DATA \n"
"Valor do Aluguel no mês de Janeiro 189 202 14 R$ \n"
"Valor da Comissão no mês de Janeiro 203 216 14 R$ \n"
"Valor do Imposto no mês de Janeiro 217 230 14 R$ \n"
"Valor do Aluguel no mês de Fevereiro 231 244 14 R$ \n"
"Valor da Comissão no mês de Fevereiro 245 258 14 R$ \n"
"Valor do Imposto no mês de Fevereiro 259 272 14 R$ \n"
"Valor do Aluguel no mês de Março 273 286 14 R$ \n"
"Valor da Comissão no mês de Março 287 300 14 R$ \n"
"Valor do Imposto no mês de Março 301 314 14 R$ \n"
"Valor do Aluguel no mês de Abril 315 328 14 R$ \n"
"Valor da Comissão no mês de Abril 329 342 14 R$ \n"
"Valor do Imposto no mês de Abril 343 356 14 R$ \n"
"Valor do Aluguel no mês de Maio 357 370 14 R$ \n"
"Valor da Comissão no mês de Maio 371 384 14 R$ \n"
"Valor do Imposto no mês de Maio 385 398 14 R$ \n"
"Valor do Aluguel no mês de Junho 399 412 14 R$ \n"
"Valor da Comissão no mês de Junho 413 426 14 R$ \n"
"Valor do Imposto no mês de Junho 427 440 14 R$ \n"
"Valor do Aluguel no mês de Julho 441 454 14 R$ \n"
"Valor da Comissão no mês de Julho 455 468 14 R$ \n"
"Valor do Imposto no mês de Julho 469 482 14 R$ \n"
"Valor do Aluguel no mês de Agosto 483 496 14 R$ \n"
"Valor da Comissão no mês de Agosto 497 510 14 R$ \n"
"Valor do Imposto no mês de Agosto 511 524 14 R$ \n"
"Valor do Aluguel no mês de Setembro 525 538 14 R$ \n"
"Valor da Comissão no mês de Setembro 539 552 14 R$ \n"
"Valor do Imposto no mês de Setembro 553 566 14 R$ \n"
"Valor do Aluguel no mês de Outubro 567 580 14 R$ \n"
"Valor da Comissão no mês de Outubro 581 594 14 R$ \n"
"Valor do Imposto no mês de Outubro 595 608 14 R$ \n"
"Valor do Aluguel no mês de Novembro 609 622 14 R$ \n"
"Valor da Comissão no mês de Novembro 623 636 14 R$ \n"
"Valor do Imposto no mês de Novembro 637 650 14 R$ \n"
"Valor do Aluguel no mês de Dezembro 651 664 14 R$ \n"
"Valor da Comissão no mês de Dezembro 665 678 14 R$ \n"
"Valor do Imposto no mês de Dezembro 679 692 14 R$ \n"
"Tipo do Imóvel 693 693 1 X \n"
"Endereço do Imóvel 694 753 60 X \n"
"CEP 754 761 8 N \n"
"Código do Município do Imóvel 762 765 4 N \n"
"Reservado 766 785 20 Branco(s) \n"
"UF 786 787 2 X \n"
"Reservado 788 797 10 Branco(s) \n"
"Delimitador de Registro 798 799 2 EOL ")
subst = "addInRegistro(\\1, \\2, registro.getTipo());\\n"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.