re = /(\[.*?\].*?\[\/.*?\])/
str = 'This in text [bar](rec)[/bar] [foo](big)[/foo] color'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end