re = /^[^-]+-[^-]+-[^_]+_([0-9]+\.){3}[0-9]+$/m
str = 'DYYU-tx-6.7.9.7_6.1.1.0
DYYU-tx-6.7.9.7_60.11.11.09
DYYU-tx-60.70.90.70_6.1.1.0'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end