# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\"(?=(?:(?:[^<](?!%>))*(?:<%[^%]+%>)(?:[^<](?!%>))*)*$)"
test_str = ("select \"SomethingQuoted\", \"SomethingQuoted\" , \"SomethingQuoted\" , \"SomethingQuoted\" to_char(max(decode( landing_name,'DX_L_MDC_RDM', BATCH_ID , -1))) as MDC_RDM_BATCH_ID\n"
" ,to_char(max(decode( landing_name,'DX_L_ESB_SPARK', BATCH_ID , -1))) as ESB_SPARK_BATCH_ID\n"
"from (\n"
"select max(u.batch_id) as BATCH_ID , u.landing_name\n"
" from \"<%=odiRef.getSchemaName(\"DJC_METADATA\",\"D\")%> .u$dx_batch_log u\n"
"\"SomethingQuoted\"\n"
" join <%=odiRef.getSchemaName(\"DJC_METADATA\",\"D\")%> .djc$dx_landing la\n"
" on u.landing_name = la.landing_name\n"
" and u.batch_id >= la.last_deleted_batch_id\n"
" join <%=odiRef.getSchemaName(\"DJC_METADATA\",\"D\")%> .djc$load_log lo\n"
" on u.load_id = lo.load_id\n"
" and lo.status = 'COMPLETE'\n"
" and lo.load_id > 0\n"
" \"SomethingQuoted\" \n"
" \"SomethingQuoted\" \n"
" where u.landing_name in ('DX_L_MDC_RDM', 'DX_L_ESB_SPARK')\n"
" and u.chkp_status = 'FINISHED'\n"
" group by u.landing_name\n"
" ) \"<%==\" \"=%>\n\n\n")
subst = "#"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.