re = /(?<![\p{L}\d])old(?![\p{L}\d])/m
str = 'age_old -> old_age but not -> bold'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end