import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=(.{0,1500}language[^\\n]*\\n[^\\n]*\\n[^\\n]*))(?=(.{0,1500}experience[^\\n]*\\n[^\\n]*\\n[^\\n]*))(?=(.{0,1500}acquire[^\\n]*\\n[^\\n]*\\n[^\\n]*))";
final String string = "materials the in the case of language\n"
+ "what was taken further than assumed sort\n"
+ "of again though experiments but seems\n"
+ "obvious is that the basic elements\n"
+ "of language say concepts or words if\n"
+ "there's any difference between them\n"
+ "those must be primarily generated\n"
+ "internally their complexity and richness\n"
+ "is such that they can't possibly be\n"
+ "acquired from experience they were what\n"
+ "were called the common notions or innate\n"
+ "ideas formed by some internal generative\n"
+ "process that's structured in some\n"
+ "fashion this and there was a good but\n"
+ "about how this is done suggesting that\n"
+ "what's involved is you start with but\n"
+ "are now called gustave properties\n"
+ "notions of casual relation notions of\n"
+ "agency anthropomorphic perspectives all\n"
+ "familiar with the way we perceive and\n"
+ "think about the natural world\n"
+ "so you see you you talk about a comet as\n"
+ "aiming towards the Earth and fortunately\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}