re = /^(?=(.{0,1500}language[^\n]*\n[^\n]*\n[^\n]*))(?=(.{0,1500}experience[^\n]*\n[^\n]*\n[^\n]*))(?=(.{0,1500}acquire[^\n]*\n[^\n]*\n[^\n]*))/m
str = 'materials the in the case of language
what was taken further than assumed sort
of again though experiments but seems
obvious is that the basic elements
of language say concepts or words if
there\'s any difference between them
those must be primarily generated
internally their complexity and richness
is such that they can\'t possibly be
acquired from experience they were what
were called the common notions or innate
ideas formed by some internal generative
process that\'s structured in some
fashion this and there was a good but
about how this is done suggesting that
what\'s involved is you start with but
are now called gustave properties
notions of casual relation notions of
agency anthropomorphic perspectives all
familiar with the way we perceive and
think about the natural world
so you see you you talk about a comet as
aiming towards the Earth and fortunately
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end