#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?sm)^(\d+) 0 obj(?:(?!^\d+ 0 obj$).)*?\/Type\s*\/Page\s.*?endobj$"
Local $sString = "%PDF-1.3" & @CRLF & _
"%¦¦¦¦" & @CRLF & _
"" & @CRLF & _
"1 0 obj" & @CRLF & _
"<<" & @CRLF & _
"/Type /Catalog /AcroForm << /Fields [12 0 R 13 0 R] /NeedAppearances false /SigFlags 3 /Version /1.7 /Pages 3 0 R /Names << >> /ViewerPreferences << /Direction /L2R >> /PageLayout /SinglePage /PageMode /UseNone /OpenAction [0 0 R /FitH null] /DR << /Font << /F1 14 0 R >> >> /DA (/F1 0 Tf 0 g) /Q 0 >> /Perms << /DocMDP 11 0 R >>" & @CRLF & _
"/Outlines 2 0 R" & @CRLF & _
"/Pages 3 0 R" & @CRLF & _
">>" & @CRLF & _
"endobj" & @CRLF & _
"" & @CRLF & _
"2 0 obj" & @CRLF & _
"<<" & @CRLF & _
"/Type /Outlines" & @CRLF & _
"/Count 0" & @CRLF & _
">>" & @CRLF & _
"endobj" & @CRLF & _
"" & @CRLF & _
"3 0 obj" & @CRLF & _
"<<" & @CRLF & _
"/Type /Pages" & @CRLF & _
"/Count 2" & @CRLF & _
"/Kids [ 4 0 R 6 0 R ]" & @CRLF & _
">>" & @CRLF & _
"endobj" & @CRLF & _
"" & @CRLF & _
"4 0 obj" & @CRLF & _
"<<" & @CRLF & _
"/Type /Page" & @CRLF & _
"/Parent 3 0 R" & @CRLF & _
"/Resources <<" & @CRLF & _
"/Font <<" & @CRLF & _
"/F1 9 0 R" & @CRLF & _
">>" & @CRLF & _
"/ProcSet 8 0 R" & @CRLF & _
">>" & @CRLF & _
"/MediaBox [0 0 612.0000 792.0000]" & @CRLF & _
"/Contents 5 0 R" & @CRLF & _
">>" & @CRLF & _
"endobj" & @CRLF & _
"" & @CRLF & _
"5 0 obj" & @CRLF & _
"<< /Length 1074 >>" & @CRLF & _
"stream" & @CRLF & _
"2 J" & @CRLF & _
"BT" & @CRLF & _
"0 0 0 rg" & @CRLF & _
"/F1 0027 Tf" & @CRLF & _
"57.3750 722.2800 Td" & @CRLF & _
"( A Simple PDF File ) Tj" & @CRLF & _
"ET" & @CRLF & _
"BT" & @CRLF & _
"/F1 0010 Tf"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")