import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<img.+?src=\"(.+?)\"[^\\}]+>";
final String string = "<![CDATA[<p>Buganda Road Chief Magistrate James Mawanda Eremye has released Makerere University administrator Edward Kisuze. The suspended administrator is accused of sexually harassing a student. Court told Kisuzze to pay cash bail of Shs2m and each of his three sureties Shs10m.</p>\n\n"
+ " <p><a href=\"http://matookerepublic.com/wp-content/uploads/2018/04/kisuze.png\"><img class=\"alignnone wp-image-32386\" src=\"http://matookerepublic.com/wp-content/uploads/2018/04/kisuze-300x175.png\" alt=\"\" width=\"680\" height=\"396\" srcset=\"http://matookerepublic.com/wp-content/uploads/2018/04/kisuze-300x175.png 300w, http://matookerepublic.com/wp-content/uploads/2018/04/kisuze-696x405.png 696w, http://matookerepublic.com/wp-content/uploads/2018/04/kisuze.png 720w\" sizes=\"(max-width: 680px) 100vw, 680px\" /></a></p>\n\n"
+ " <p>However, before releasing him the magistrate ordered the prosecutor to disclose to the defence the evidence to enable commencement of hearing of this case come <span data-term=\"goog_350196878\">May 28 2018</span>.</p>\n\n"
+ "<p>On April 14, police arrested Kisuze after a viral picture of him kissing the student’s private parts in office was released online. On May 4<sup>,</sup> he appeared before court and was remanded to Luzira prison after pleading not guilty to charges.</p>\n"
+ "]]>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}