package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[\*\*\].*?\](?<etCapturedData>[^\[]+)\s*\[\*\*\]`)
var str = `12/27-13:46:30.535369 [**] [1:2019876:2] ET SCAN SSH BruteForce Tool with fake PUTTY version [**] [Classification: Detection of a Network Scan] [Priority: 3] {TCP} 100.31.116.39:35016 -> 172.20.16.2:22
12/27-13:34:12.027500 [**] [1:2500056:4184] ET COMPROMISED Known Compromised or Hostile Host Traffic TCP group 30 [**] [Classification: Misc Attack] [Priority: 2] {TCP} 100.83.149.133:58061 -> 172.20.16.2:22
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}