re = /(?:product:\s+")(.+?)(?:")/m
str = '{
name: "something"
product: "ABC-123"
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end